Příkazy Cisco IOS

Z Wikiknih
Přejít na: navigace, hledání

Cisco IOS (původně Internetwork Operating System) je operační systém používaný na směrovačích a přepínačích firmy Cisco Systems.

Přehled módů[editovat]

Základní módy a příkazy, kterými lze mezi těmito módy přecházet:

Základní módy Cisco IOS

Klávesové zkratky[editovat]

  • Šipka nahoru () nebo Ctrl+P - zobrazí předchozí příkaz
  • Šipka dolů () nebo Ctrl+N - zobrazí následující příkaz
  • Šipka doprava () nebo Ctrl+F - posun o jeden znak vpřed
  • Šipka doleva () nebo Ctrl+B - posun o jeden znak zpět
  • Tab - automatické doplnění příkazu
  • ? - zobrazí nabídku dostupných příkazů (podle doposud napsaných znaků)

Uživatelský mód (User Mode)[editovat]

Mód, ve kterém se nacházíte po navázání relace s routerem/switchem. Neumožňuje měnit konfiguraci.

enable
Vstup do privilegovaného módu
ping [...]
Příkaz PING zjišťuje dostupnost cíle pomocí protokolu ICMP.
traceroute [...]
Trasování cesty k cíli pomocí protokolu ICMP.
exit
Příkaz ukončí relaci.
logout
Příkaz ukončí relaci.
show
Příkaz zobrazí nejrůznější informace.
show flash
Příkaz zobrazí informace o vnitřní paměti FLASH.
show ip interface [...]
Příkaz zobrazí informace o fyzických rozhraních (např. Serial1/0), na kterých je nakonfigurován IP.
show ip route
Příkaz zobrazí routovací tabulku.
show version
Příkaz zobrazí informace o hardwaru, IOS, rozhraních, paměti a konfiguračním registru.
show clock
Příkaz zobrazí nastavený datum a čas.
show history
Příkaz zobrazí seznam naposledy použitých příkazů.
show interfaces [...]
Příkaz zobrazuje všechny informace o rozhraních.
telnet [...]
Telnet klient (pro připojení ke vzdáleným systémům).
disconnect ...
Odpojí navázanou relaci.
show sessions
Zobrazí seznam navázaných spojení.
  • Ctrl+Shift+6, pak x - "uspí" aktivní relaci
terminal history [...]
Příkaz nastaví velikost bufferu pro uchovávání zadaných příkazů.

Privilegovaný mód (Privileged Mode)[editovat]

Mód, ve kterém je možno provádět změnu konfigurace.

disable
Způsobí návrat do uživatelského módu (User Mode).
setup
Spustí konfigurační utilitu (postupně se formou jednoduchých otázek zeptá na základní konfiguraci).
clock set [...]
Příkaz nastaví čas.
debug ...
Zapne různé ladící výpisy.
debug ip rip
Zapne ladící výpisy pro routovací protokol RIP.
debug ip igrp ...
Zapne ladící výpisy pro routovací protokol IGRP.
debug all
Zapne všechny ladící výpisy.
debug ppp negotiation
Zapne ladící výpisy pro ověřování v protokolu PPP.
clear ...
Resetovací funkce.
clear arp-cache
Vymaže ARP cache (tabulka obsahující k IP adresám jejich MAC adresy).
clear ip route *
Vymaže routovací tabulku.
config
configure terminal
Vstoupí do konfiguračního módu.
copy running-config tftp
Zkopíruje současnou konfiguraci na TFTP server (soubor).
reload
Restartuje IOS.

Konfigurační mód (Configuration Mode)[editovat]

Hlubší konfigurace routeru/switche.

end

nebo klávesová zkratka Ctrl+Z

návrat do privilegovaného módu
hostname ...
Příkaz nastaví jméno zařízení (routeru/switche).
line ...
Nastavuje způsob přihlašování ke konzoli a virtuálním terminálům.
line console 0
password <heslo>
login
Konfiguruje konzoli (potřeba zadat heslo).
line vty 0 4
password <heslo>
login
Konfiguruje virtuální terminály 0 - 4 (potřeba zadat heslo).
enable password <heslo>
Zapne potřebu zadání hesla při přechodu do konfiguračního módu.
enable secret <heslo>
Heslo pro přechod do konfiguračního módu (bude uloženo zašifrované).
interface <typ> [<slot>/]<port>
Vstoupí do konfigurace rozhraní.
banner motd <znak>
Nastaví popis routeru ukončený daným znakem.
ip ...
Konfiguruje IP protokol.
ip host <jméno> <adresy>
Přidá IP adresy pod jméno daného zařízení.
boot system ...
Nastaví, z kterého umístění se má při startu natáhnout IOS.

Konfigurace rozhraní (Interface Mode)[editovat]

Příkazy společné nastavování různých rozhraní.

ip ...
Nastavuje protokol IP.
ip address <adresa> <maska>
Nastaví na daném rozhraní danou IP adresu.
shutdown
Vypne rozhraní.
no shutdown
Zapne rozhraní.
description <popis>
Nastaví popis daného rozhraní.

Konfigurace routeru[editovat]

Tyto příkazy fungují pouze na směrovačích (ne na přepínačích).

Přístup přes SSH[editovat]

Postup při konfiguraci přístupu přes SSH

hostname <jmeno>
Konfigurace jména routeru.
ip domain-name <domena.com>
Konfigurace jména domény.
crypto key generate rsa
Vygenerovaní rsa klíče.
username <jmeno_uzivatele> secret <heslo>
Vytvoření uživatele s heslem
line vty 0 4
transport input ssh
login local
Vytvoření virtuálních terminálů 0 - 4 s přístupem přes ssh a pro příhlašování se použije lokální uživatel s heslem

CDP[editovat]

Práce s Cisco Discovery Protocol.

cdp run
V konfiguračním módu - zapne CDP na všech rozhraních.
cdp enable
V konfiguraci rozhraní - zapne CDP na daném rozhraní.
show cdp
Zobrazí informace o CDP.
show cdp entry ...
Zobrazí informace o daném sousedovi.
show cdp interface
Zobrazí informace o rozhraních, na kterých běží CDP.
show cdp neighbors
V privilegovaném módu - zobrazí sousedy.
clear cdp table
Smaže tabulku sousedů.
clear cdp counters
Resetuje čítače přenosů dat.
show cdp traffic
Zobrazí množství přenesených dat mezi sousedy.
debug cdp ...
Zapne ladící výpisy CDP.
cdp timer
Nastaví interval zasílání CDP updatů.

ACL[editovat]

Práce s ACL (Access Control List).

access-list <číslo typu protokolu> {deny|permit} <adresa> <wildchar maska>

V konfiguračním módu přidá pravidlo do seznamu s daným číslem (pro IP 1-99).

ip access-group <číslo acl> ...
V konfiguraci rozhraní aplikuje ACL (i pojmenovaný) na daný traffic (in/out).
show access-lists
Zobrazí seznam ACL.
access-list <číslo typu protokolu> {deny|permit} <protokol> <adresa> <wildchar maska> ...

Rozšířené IP ACL (s čísly 100 - 199). Možnost filtrace podle transportního protokolu i podle čísel portů.

ip access-list extended <jméno>
Vytváří pojmenovacý ACL.

Statické směrování[editovat]

Nastavování statických routovacích záznamů.

ip route <cílová síť> <maska> <odchozí rozhraní>
V konfiguračním módu přidá statický směrovací záznam.
ip route 0.0.0.0 0.0.0.0 <odchozí rozhraní>
Výchozí brána pro nepřímo připojené sítě.
show ip route
Zobrazí směrovací tabulku.
ip default-network <adresa sítě>
Nastaví defaultní cestu.

RIP směrování[editovat]

Nastavování routovacícho protokolu RIP (Routing Information Protocol).


ip route <cílová síť> <maska> <odchozí rozhraní>
V konfiguračním módu přidá statický směrovací záznam.
ip route 0.0.0.0 0.0.0.0 <odchozí rozhraní>
Výchozí brána pro nepřímo připojené sítě.
show ip route
Zobrazí směrovací tabulku.
ip default-network <adresa sítě>
Nastaví defaultní cestu.
router rip
Vstoupí do konfigurace protokolu RIP (z konfiguračního módu).
network <síť>
Přidá síť, se kterou má protokol RIP pracovat.
no network <síť>
Odebere síť.
version <verze>
Nastaví verzi protokolu RIP (1/2).
show ip route
Zobrazí routovací tabulku.
show ip protocols
Zobrazí informace o routovacím protokolu.
debug ip rip
Zapne ladící výpisy.
show ip rip database
Zobrazí databázi cest protokolu RIP.
passive-interface <rozhraní>
Na daném rozhraní se bude pouze naslouchat (ne vysílat).

IGRP směrování[editovat]

Nastavování routovacícho protokolu IGRP (Interior Gateway Routing Protocol).


router igrp ...
Vstoupí do režimu konfigurace protokolu IGRP. Parametrem je číslo autonomního systému.
network <síť>
Přidá síť, se kterou má IGRP pracovat.
no network <síť>
Odebere síť.
show ip route
Zobrazí routovací tabulku.
show ip protocols
Zobrazí informace o IGRP (intervaly updatů, ...).
no router igrp ...
Vypne IGRP.
debug ip igrp ...
Zapne ladící výpisy.

OSPF směrování[editovat]

Konfigurace OSPF (Open Shortest Path First).


router ospf <číslo procesu>
Vstoupí do konfigurace OSPF.
network <adresa> <wildchar maska> area <area ID>
Přidá síť, area ID pro páteřní sítě musí být rovno 0.
area <area ID> authentication message-digest
Zapne autentizaci mezi routery.
ip ospf priority <priorita>
V konfiguraci rozhraní - nastaví prioritu routeru (0 - 255), vyšší priorita = větší pravděpodobnost zvolení routeru jako DR.
ip ospf cost <číslo ceny cesty>
Nastaví cenu cesty - vyšší číslo = horší cesta.
ip ospf message-digest-key 1 md5 7 <heslo>
Nastaví klíč (heslo) pro autentizaci mezi routery.
ip ospf hello-interval <čas>
Nastaví interval mezi hello pakety.
ip ospf dead-interval <čas>
Interval, kdy je router považován za ztracený (pokud se neozve).
show ip route
Zobrazí routovací tabulku.
show ip ospf [...]
Zobrazí různé informace o OSPF.
show ip ospf database
Zobrazí databázi cest.
debug ip ospf [...]
Zapne ladící výpisy (např. events).

EIGRP směrování[editovat]

Nastavení směrovacího protokolu EIGRP (Enhanced Interior Gateway Routing Protocol).


router eigrp <číslo autonomního systému>
V konfiguračním módu. Vstoupí do konfigurace EIGRP. Číslo autonomního systému může korespondovat s IGRP (EIGRP přeposílá cesty IGRP se stejným číslem).
network <síť>
Přidá síť, se kterou má EIGRP pracovat.
show ip route
Zobrazí routovací tabulku.
show ip eigrp neighbors
Zobrazí sousední routery s EIGRP.
show ip eigrp topology
Zobrazí tabulku topologie sítě.
debug eigrp ...
Zapne různé ladící výpisy (např. packet).
auto-summary
V konfiguraci routování. Zapne autosumarizaci (shlukování záznamů s různými maskami podsítí).
ip summary-address eigrp <autonomní číslo> <síť> <maska>
Autosumarizace na rozhraní.
ip authentication mode eigrp <číslo aut. systému> md5
ip authentication key-chain eigrp <aut. č.> <název klíče>
V konfiguraci rozhraní. Zapne autentizaci MD5 klíčem.
key chain <název klíče>
V konfiguračním módu. Vstoupí do konfigurace klíče.
key <číslo klíče>
key-string <text>
Nastaví klíč.

NAT/PAT[editovat]

Konfigurace překladu adres NAT/PAT (Network Address Translation/Port Address Translation).


ip nat inside source static <vnitřní IP> <vnější ip>
Provede pevnou (statickou) konfiguraci NAT (vnitřní IP <=> vnější IP). V konfiguračním režimu.
ip nat inside
V konfiguraci rozhraní. Identifikuje rozhraní na vnitřní síti.
ip nat outside
V konfiguraci rozhraní. Identifikuje rozhraní na vnější síti.
ip nat pool <jméno> <od IP> <do IP> netmask <maska sítě>
Vytvoří pojmenovaný rozsah IP adres pro dynamický NAT.
ip nat inside source list <číslo ACL> pool <jméno>
Definuje dynamický nat s daným ACL a daným rozsahem adres. ACL by mel povolovat vnitřní rozsah (permit).
ip nat inside source list <číslo ACL> interface <rozhraní> overload
Definuje PAT (využívá čísla portů k adresování počítačů ve vnitřní síti).
clear ip nat translation *
Smaže všechny dynamické záznamy.
show ip nat translation
Zobrazí aktivní překlady.

DHCP[editovat]

Konfigurace DHCP (Dynamic Host Configuration Protocol).

ip dhcp pool <jméno>
Vstoupí do konfigurace DHCP.
network <adresa> <maska>
Specifikuje rozsah přidělovaných adres.
default-router
Specifikuje přidělovanou výchozí bránu.
dns-server
Přidělovaný DNS server.
ip dhcp excluded-address <od IP> <do IP>
Adresy, které nebudou přidělovány. V konfiguračním módu.
show ip dhcp binding
Zobrazí tabulku propůjčených adres.
debug ip DHCP server events
Zapne ladící výpisy.
ip helper-address <adresa>
V konfiguraci rozhraní. Vytvoří DHCP relay. Router se bude tvářit jako DHCP a bude komunikovat se skutečným DHCP serverem.

PPP[editovat]

Nastavení protokolu PPP (Point-to-Point Protocol).


encapsulation ppp
Při konfiguraci rozhraní. Zapne PPP.
ppp authentization [PAP|CHAP]
Zapne algoritmus autentizace.
ppp pap sent-username <jméno> password <heslo>
Jméno, kterým se identifikuje rozhraní.
username <jméno> password <heslo>
V konfiguračním módu. Přidá vzdáleného uživatele.
compress [predictor|stac]
Nastaví algoritmus komprese.
debug ppp authentication
Zapne ladící výpisy autentizace PPP.

ISDN[editovat]

Konfigurace ISDN (Integrated Services Digital network).

isdn switch-type <typ switche>
Nastavuje typ ISDN switche, se kterým router komunikuje. Např. basic-ni.
isdn spid{1|2} <SPID číslo> [<lokální číslo>]
Nastaví přiřazené SPID číslo. V konfiguraci rozhraní BRI.
controller <controller> <slot>/<port>
Vstoupí do menu controller.
pri-group timeslots <rozsah>
Nastaví port jako PRI.
show isdn status
Zobrazí informace o ISDN spojení.
show interface bri0/0
Zobrazí statistiky pro konkrétní rozhraní routeru.
show isdn active
Zobrazi probíhající spojení.
debug isdn ...
Ladící výpisy.
dialer-list <číslo> protocol op permit
Vytvoří vytáčecí seznam.
dialer-group <číslo>
Přiřadí rozhraní do vytáčecího seznamu. V konfiguraci rozhraní BRI.

Frame-Relay[editovat]

Nastavování Frame relay.


encapsulation frame-relay [IETF]
Zapne na daném rozhraní frame-relay. V konfiguraci rozhraní.
bandwidth <číslo>
Nastaví šířku přenosu. např. 64.
frame-relay lmi-type ansi
Nastaví se jen na jedné straně linky.
frame-relay map ip <adresa druhé strany> <číslo> broadcast [IETF]
Nastaví routeru adresu druhé strany spoje.
show frame-relay map
Zobrazí tabulku frame-relay routerů.
debug frame-relay ...
Ladící výpisy.

Konfigurace switche[editovat]

Příkazy pouze pro přepínače (ne směrovače).

Layer 3 přístup[editovat]

Konfigurace L3 přístupu k přepínači.

Switch(config)#interface VLAN 1
Switch(config-if)#ip address 192.168.1.2 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.1.1
Switch#show interace VLAN 1

Nastaví IP adresu na VLAN switche.

STP[editovat]

Konfigurace STP (Spanning Tree Protocol).


show spanning-tree brief
Zobrazí zprávu o STP.
spanning-tree vlan 1 priority <priorita>
Nastaví prioritu STP na vlan 1.

Správa tabulky MAC adres[editovat]

Konfigurace tabulky MAC adres.


show mac-address-table
Zobrazení tabulky.
show mac-address-table static
Zobrazení statických záznamů.
clear mac-address-table dynamic
Vymazání dynamických záznamu.
mac-address-table static <MAC adresa> interface <rozhraní> ...
Přidá statický záznam o MAC adrese do tabulky MAC adres. Možno specifikovat VLAN.
switchport port-security ...
Na daném rozhraní nastaví zabezpečení (např. jen pro danou staticky nastavenou MAC adresu).

VLAN[editovat]

Konfigurace VLAN.


show vlan
Zobrazí tabulku VLAN.
vlan database
Vstoupí do konfigurace VLAN.
vlan <číslo> name <jméno>
Přidá VLAN.
no vlan <číslo>
Odebere VLAN.
delete flash:vlan.dat
Smaže databázi VLAN v paměti FLASH.
switchport mode {access|trunk}
V konfiguraci rozhraní. Nastaví mód přenosu přes spoj.
switchport access vlan <číslo>
Přiřadí rozhraní do VLAN.
no switchport access vlan <číslo>
Odebere rozhraní z VLAN.
switchport trunk encapsulation <typ>
Nastaví obalování paketů v režimu trunk na <typ>.
interface <rozhraní> <slot>/<port>.<subport>
Konfigurace subrozhraní na daném rozhraní (pro routování mezi VLAN).

Externí odkazy[editovat]